Главная страница > Вопрос
Вопрос
Всем привет. Помогите решить задачу на 1С.
Компьютеры | программирование | windows | | 1C 07.09.11 Автор: Без имени
Ответы
1 из 2
Ну я бы реализовал это следующим образом:
В регистре остатков у меня были бы измерения, к примеру:
- Фирма, - МестоХранения, - Товар, - Ряд, - Стеллаж
далее, ряд и стеллаж - это справочники с кодом типа (Число) или сделать отдельный реквизит, а-ля ПорядковыйНомер
Перед печатью документа делается выборка по нужному нам товару, при этом сортируется по ПорядковыйНомер (ряда, затем стеллажа) и берется первое попавшееся значение.

Ближайший и дальнележащий товар мы получаем простым направлением сортировки в запросе ВОЗР/УБЫВ.

Всё элементарно )


1. На счет "двух глобальных переменных" - это тебе поможет только при первоначальном заполнении склада. Когда товар продастся, ячейка освободится и ее надо будет заполнить.

2. Реализация твоего случая. Создай документ, к примеру "НачальноеЗаполнениеСтруктурыСклада". Создай товар с чисто символическим названием "ПустаяЯчейка".
Прогони циклом

Для р=1 По КоличествоРядов Цикл
     Для с=1 По КоличествоСтеллажей Цикл
             //тут записать в вышеуказанный регистр остатков: фирму, МХ, пустуюЯчейку, р, с, КвоРавно_0;
     КонецЦикла;
КонецЦикла;

Так, представление матрицы ячеек у нас уже есть

При записи приходного документа делаем запрос:

Пока ТаблЧасть.ПолучитьСтроку() Цикл //я сокращенно, только идею
   Для к=1 По ТаблЧасть.КоличествоТовара Цикл // тут мы разбиваем на отдельные штуки
         Выбрать ПЕРВЫЕ 1 товар "ПустаяЯчейка" и упорядочить ПО ПорядковыйНомер (получаем выборку пустых 1 шт ячеек), далее
         пишем в эту ячейку, фирма, МХ, товар, ряд, стеллаж, кво=1... (следующий раз запрос эту ячейку пропустит, т.к. товар не "ПустаяЯчейка")          
   КонецЦикла;
КонецЦикла;

Параллельно советую вести оборотный регистр какой-то РеализацииТовара и ВзаиморасчетыСКонтрагентами.
08.09.11 Автор: Без имени
2 из 2
Люди помогите, завтра сдавать надо эту задачу а у меня ее так и нет... не получается сделать(((((( Поделитесь!!!!!!!! x_files_1@mail.ru
17.12.11 Автор: Без имени
Это может быть интересно
Помогите понять в чем ошибка, 1с
Помогите решить задачи!!!!!!!!!!!!!!!!!
Помогите решить задачу по физике. Напишите, пож. решение
Программа 1С:Бухгалтерия скачать где-нибудь возможно ?
Помогите пжл решить задачу по алгебре, вопрос жизни и смерти
Войти
Просмотреть Вопросы и ответы в версии: для мобильных устройств | для ПК
©2014 Google - Политика конфиденциальности - Справка